Luxonis - Devices shown as offline / device communication disrupted – Incident details

Devices shown as offline / device communication disrupted

Resolved
Operational
Started 26 days agoLasted 36 minutes

Affected

Hub

Major outage from 9:04 AM to 9:40 AM, Partial outage from 9:04 AM to 9:40 AM

API

Partial outage from 9:04 AM to 9:40 AM

Device Data Receiver

Major outage from 9:04 AM to 9:40 AM

Updates
  • Resolved
    Resolved

    On February 14th, between 08:33 and 10:40 CET, users experienced a service disruption in the Luxonis Hub dashboard where all devices appeared offline, and most dashboard functionality was unavailable. The Web Terminal service remained operational throughout the incident.

    The root cause was identified as a race condition triggered by a critical infrastructure component update. This incident revealed gaps in our monitoring coverage, which resulted in delayed response time as we were alerted to the issue through user reports rather than our internal monitoring systems.

    Remediation steps:

    1. We are implementing a fix to eliminate the identified race condition in an upcoming release

    2. We are expanding our infrastructure monitoring coverage to prevent similar detection delays in the future

    We apologize for any inconvenience this may have caused and thank our users for their prompt reporting of the issue.

  • Investigating
    Investigating

    We received reports of devices being shown as offline.